Tyro Service Status

Medicare Easyclaim Issues
Incident Report for Tyro Platform Service
Resolved
The Medicare Easyclaim services degradation has now been resolved.

Any failed transactions will need to be resubmitted.
Posted Apr 19, 2018 - 13:34 AEST
Monitoring
Medicare is experiencing intermittent issues, which may affect Medicare Easyclaim from being processed. Any failed submissions will need to be resubmitted.

This issue is outside Tyro's control however we are actively monitoring any update/progress to ensure our systems return to normal as soon as the issue is resolved.

Customers should contact Medicare directly for anything urgent.
Posted Apr 19, 2018 - 11:03 AEST
This incident affected: Medicare Easyclaim.