Tyro Service Status

Settlement Delay
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 16:10 AEST
Monitoring
Due to the upcoming public holiday, you may experience a delay to your settlement payments. If your settlement is made into an external bank account, please note your funds may appear in your account at a later time than what you have previously experienced.
Posted Sep 21, 2022 - 17:18 AEST
This incident affected: Settlement.