Tyro Service Status

Scheduled maintenance
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Jul 13, 2018 - 07:53 AEST
Monitoring
Please be advised that Tyro Payments Ltd will be performing scheduled maintenance Thursday, 12th July from 00:30 to 04:30.

During the maintenance period, Tyro is taking precautionary action to minimise impacts to merchants.
Posted Jul 12, 2018 - 17:07 AEST
This incident affected: Transaction Processing Systems.