Tyro Service Status

Issue with Medicare Easyclaim transactions
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 13:50 AEST
Update
We are currently experiencing an issue, which is affecting some Medicare Easyclaim transactions from being processed.

We are actively working to resolve this issue and will provide updates when they become available.

As a workaround, please process the claim through your PMS which will provide the rebate in approximately 3 business days.

We’re sorry for any inconvenience caused.
Posted Jul 27, 2021 - 13:18 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jul 27, 2021 - 12:49 AEST
This incident affected: Medicare Easyclaim.