Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Oct 05, 2018 - 16:32 AEST
Investigating
We are currently experiencing issues which may affect the ability to process transactions.

We're in the process of investigating and will provide further updates shortly.

In the meantime, please try an alternative payment method.
Posted Oct 05, 2018 - 13:18 AEST
This incident affected: Transaction Processing Systems.