Tyro Service Status

Technical issues impacting some services
Incident Report for Tyro Platform Service
Postmortem

Issue Summary

On June 14th between 1.01am – 2.12am some customers experienced issues with reporting on the terminal and merchant portal.

Tyro incident number

283648

Description

During the affected time, a small number of our customers were unable to see reports in the Merchant Portal and on terminals. Between 1.47am and 6am, paper roll ordering service was impacted.

Technical root cause

One of Tyro’s datacenters lost connectivity to its provider during their scheduled maintenance. The provider’s failover mechanism did not activate properly and Tyro’s failover mechanisms did not account for this particular scenario. This led to an unintended outage for Tyro’s reporting services.

Communication to customers

Tyro’s status page was updated during the identification, monitoring and resolution stages of the incident.

Remediation

We shut down the reporting service in the affected datacentre and redirected traffic to the unaffected datacentre.

Prevention

Tyro maintains multiple levels of redundancy. Having a redundant provider link enables us to re-route traffic to minimise the impact to our customers. Pre-emptively switching over to a redundant provider link not affected by the provider’s scheduled maintenance, will help mitigate the impact.

Posted Jun 26, 2019 - 15:53 AEST

Resolved
Reconciliation and settlement reports were recently unavailable on terminals and the Tyro Merchant Portal. All reports should now be showing as normal and all other services that were impacted have been restored. Tyro apologises for any inconvenience caused.
Posted Jun 14, 2019 - 10:31 AEST
Monitoring
Reconciliation and settlement reports were recently unavailable on terminals and in the Tyro Merchant Portal. This has now been resolved and these can now be accessed and printed. We are continuing to monitor other affected services. Tyro apologies for any inconvenience caused.
Posted Jun 14, 2019 - 02:55 AEST
Investigating
We have identified a technical issue that might affect some of our services. We are working to resolve this issue and will provide further updates shortly. Apologies for the inconvenience caused.
Posted Jun 14, 2019 - 02:29 AEST
This incident affected: Reconciliation & Settlement Reports.