Tyro Service Status

Identified Telstra network issue – Queensland
Incident Report for Tyro Service Status for Customers
Resolved
Tyro's machine connection was recently unavailable due to an issue with Telstra's communication network.

This issue is now resolved.

We’re sorry for any inconvenience caused to our customers.
Posted Nov 22, 2019 - 20:24 AEDT
Monitoring
Telstra has identified an issue with their communications network in Northern Queensland. The problem appears to be impacting Mobile Connectivity to the 3G/4G Network for Tyro EFTPOS machines.

This issue is outside Tyro’s control, however we are actively monitoring the situation and will update this page when information becomes available.

For our customers impacted by this issue, we recommend switching to Wifi or Ethernet connection if available.

For information on how to switch from 3G to wifi can be found here - https://help.tyro.com/s/article/How-do-I-change-my-network-connection
Posted Nov 22, 2019 - 13:17 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Nov 22, 2019 - 12:51 AEDT
This incident affected: Transaction Processing Systems.