Tyro Service Status

Afterpay processing issues
Incident Report for Tyro Platform Service
Postmortem

Issue Summary
Some customers reported that they were not able to process Afterpay transactions from 11:30am on Thursday 15 November, until an updated Tyro Terminal Adaptor (TTA) was made available from 1:57pm on Friday 16 November.

Tyro Incident number
200470

Description of Impact
At around 11:30am on Thursday 15 November 2018, Tyro was alerted to issues with processing Afterpay transactions. Further investigation confirmed that there were difficulties processing Afterpay transactions from 10:34am on Thursday 15 November. An updated Tyro Terminal Adaptor (TTA) was made available from 1:57pm on Friday 16 November. Once this new version was manually installed by impacted merchants, the Afterpay transaction processing returned to normal.

Technical Root Cause
The recent Afterpay update was incompatible with the Tyro Terminal Adaptor (TTA) which caused transactions to decline.

Remediation
Once the issue was identified to be related to the Afterpay update, a new Tyro Terminal Adaptor (TTA) version was developed and made available to resolve the issue.

Posted Nov 22, 2018 - 18:04 AEDT

Resolved
The issue with Afterpay transactions has been resolved.
Posted Nov 22, 2018 - 16:42 AEDT
Update
Tyro has identified the cause of the Afterpay transaction issue. Our teams have developed a version of the Tyro Terminal Adaptor (TTA) that has been specifically built to address this.

Please refer to the following article https://help.tyro.com/s/article/My-Afterpay-transactions-aren-t-working which will guide you step-by-step on how to install this version of the TTA.

We apologise for any inconvenience caused.
Posted Nov 16, 2018 - 13:57 AEDT
Monitoring
There is a known issue we have identified with Afterpay and their transactions may be declined. We are actively working with Afterpay to resolve the issue. We currently do not have a time-frame for resolution, though unlikely for it to be resolved today. We will however look to update you from tomorrow when more information is available to us.

We apologise for any inconvenience caused.
Posted Nov 15, 2018 - 16:47 AEDT
Identified
There is a current issue we have identified with Afterpay and their transactions may be declined. We are actively working with Afterpay to resolve the issue and will provide further updates shortly. We apologise for any inconvenience caused.
Posted Nov 15, 2018 - 15:47 AEDT
Update
Tyro is temporarily experiencing issues with Afterpay which may affect the ability to process transactions. We are continuing to work to identify and resolve this issue and will provide further updates shortly.
Posted Nov 15, 2018 - 14:56 AEDT
Investigating
We have identified a technical issue with Afterpay. We are working to resolve this issue and will provide further updates shortly. Our status page at status.tyro.com is the best source for the most up-to-date information.
Posted Nov 15, 2018 - 13:46 AEDT
This incident affected: Transaction Processing Systems.