Tyro Service Status

Integrated transactions
Incident Report for Tyro Platform Service
Postmortem

Tyro Incident number

313268

Description of Impact

On Sunday 11th August 2019, some Tyro customers intermittently experienced slow or failed integrated transaction processing between these times (10.30am-approximately 11am, 12pm-approximately 12.30pm, 1.30pm-approximately 1.45pm). On Monday 12 August, this issue reoccurred for a very small number of Tyro customers (between 10am - 10.10am only).

Technical Root Cause

We were alerted of performance issues across our integrated transaction processing systems. Investigations identified a carrier fault which resulted in the service degradation between our cross data centre communications.

Prevention

Tyro is working with our carrier to increase proactive notifications regarding any potential service impacts.

Tyro is making improvements to further enhance our detection and failover capabilities around our cross data centre communications.

Tyro has increased the resiliency of our key integrated transaction processing systems which should improve their ability to better handle future transient connectivity issues.

Communication During Incident

Tyro’s status page (status.tyro.com) was updated with notifications sent directly to customers who had subscribed to receive them. Messaging was also included on Tyro's social media channels and the contact centre’s IVR messaging switched over to reference status page messaging.

Posted Aug 28, 2019 - 14:04 AEST

Resolved
This incident has been resolved.
Posted Aug 15, 2019 - 09:32 AEST
Update
Monitoring - Integrated transactions have returned to normal however we are closely monitoring our systems and will update this status when resolved.
Posted Aug 13, 2019 - 11:20 AEST
Monitoring
Some customers may experience intermittent delays with some integrated transactions going through. Stand alone transactions are not affected. If you're experiencing trouble with integrated transactions please find below an article on how to process standalone transactions. Please note, this will bypass the Point of Sale system and when finalising end of day reporting there will be a mismatch between the Point of Sale and the Tyro terminal. Link: https://help.tyro.com/s/article/How-do-i-process-a-Manual-Transaction-Stand-Alone.
We apologise for any inconvenience caused to our customers.
Posted Aug 12, 2019 - 10:52 AEST
This incident affected: POS Integration.