Tyro Service Status

Transaction processing
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Aug 03, 2021 - 16:39 AEST
Monitoring
Some merchants may be experiencing issues processing cards from a national banking provider. This issue is outside Tyro's control however we recommend you ask your customers to try an alternative payment method.

We will continue to actively monitor the situation.
Posted Aug 03, 2021 - 10:31 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Aug 03, 2021 - 09:56 AEST
This incident affected: Transaction Processing Systems.