Tyro Service Status

Connectivity issues
Incident Report for Tyro Platform Service
Resolved
This issue is now resolved.

We’re sorry for any inconvenience caused to our customers.
Posted Oct 28, 2020 - 16:53 AEDT
Monitoring
Tyro has identified an issue with a national Network Provider, which may be impacting terminal connectivity to the 3G Network.

This issue is outside Tyro’s control, however we are actively monitoring the situation and will update this page when information becomes available.

If you are experiencing issues please try switching from 3G to a Wifi connection by following the instructions in the below video
https://www.youtube.com/watch?v=JKdoJ-lXFns&list=PLqxK_9hF-iZ2Eh6zcfHwqjVYX3lhWGDdj
Posted Oct 28, 2020 - 15:50 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Oct 28, 2020 - 15:31 AEDT
This incident affected: EFTPOS machine connectivity.