Tyro Service Status

Settlement delay – Bendigo Bank powered by Tyro
Incident Report for Tyro Platform Service
Resolved
Update - All settlement should now be available for Bendigo Bank powered by Tyro customers.

We apologise for any inconvenience experienced.
Posted Oct 11, 2023 - 08:56 AEDT
Update
Please note – Some Bendigo Bank powered by Tyro customers may experience a delay to their settlement.

We apologise for any inconvenience experienced.
Posted Oct 11, 2023 - 08:39 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Oct 11, 2023 - 08:00 AEDT
This incident affected: Settlement.