Tyro Service Status

Identified Telstra network issue
Incident Report for Tyro Service Status for Customers
Resolved
The issue impacting Mobile Connectivity to the Telstra 3G/4G network is now resolved and all Tyro EFTPOS machines should be able to process transactions. For customers who switched to Wifi or Ethernet direct connection you may choose to revert back to the 3G network. We thank you for your patience whilst disruption was being experienced.
Posted Nov 28, 2019 - 15:35 AEDT
Identified
An issue has been identified impacting Mobile Connectivity to the Telstra 3G/4G Network including Tyro EFTPOS machines. For customers impacted we recommend switching to Wifi or Ethernet direct connection if available. Information on how to switch from 3G to wifi can be found here -https://help.tyro.com/s/article/How-do-I-change-my-network-connection

This issue is outside Tyro’s control, however we are actively monitoring the situation and will update this page when information becomes available.
Posted Nov 28, 2019 - 07:56 AEDT
This incident affected: EFTPOS machine connectivity.