Tyro Service Status

Possible system issues
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Sep 14, 2024 - 10:22 AEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2024 - 10:21 AEST
Update
Settlement has now been processed. Bendigo Bank powered by Tyro customers will receive their settlement payment a little later than normal today. We apologise for any inconvenience experienced.
Posted Sep 14, 2024 - 09:50 AEST
Update
Bendigo Bank powered by Tyro customers may experience a few hours delay to their settlement payment today. The team are working on a resolution and we'll keep updates provided here. We apologise for any inconvenience experienced.
Posted Sep 14, 2024 - 08:27 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Sep 14, 2024 - 08:08 AEST
This incident affected: Settlement.