Tyro Service Status

Tyro Bank Account issue resolved
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 19:19 AEDT
Update
All external transfers from the Tyro Bank Account have now been processed.

We’re sorry for any inconvenience caused.
Posted Nov 10, 2021 - 19:18 AEDT
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2021 - 16:14 AEDT
Identified
An issue has been identified where some transfers from the Tyro Bank Account to external bank accounts may be delayed.

We're in the process of resolving this issue and will provide further updates on this page as they become available.

We’re sorry for any inconvenience being experienced.
Posted Nov 10, 2021 - 16:14 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Nov 10, 2021 - 15:47 AEDT
This incident affected: Settlement.