Tyro Service Status

Settlement delay

Incident Report for Tyro Platform Service

Resolved

Yesterday’s issue affecting settlement to external bank accounts has now been fixed. Whilst settlement processing restarted last night, there is a backlog of payments that will take some time to clear. If you have not received your payment, please contact your external bank, as times can vary. Thank you for your ongoing patience and understanding.
Posted Jan 28, 2026 - 13:00 AEDT

Identified

Some customers who settle into an external bank account will experience a delay to their payment today. Whilst this issue is outside Tyro’s control, we understand and apologise for the inconvenience this may cause.
Posted Jan 27, 2026 - 13:46 AEDT
This incident affected: Settlement.