Tyro Service Status

Tyro App Home Screen - Android users only
Incident Report for Tyro Service Status for Customers
Resolved
A display issue with the home page for the Tyro App (Android version only) occurred between 5.45pm and 6.15pm. This issue is now resolved and we're sorry for any inconvenience caused.
Posted Mar 04, 2020 - 18:29 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Mar 04, 2020 - 17:56 AEDT