Tyro Service Status

Tyro App Loan Eligibility page update
Incident Report for Tyro Service Status for Customers
Resolved
The Tyro App’s Loan Eligibility page was recently unavailable. This issue is now resolved.

We’re sorry for any inconvenience experienced.
Posted Jan 14, 2022 - 21:28 AEDT
Update
An issue has been identified with the Tyro App’s Loan Eligibility page.

This issue is outside Tyro's control however we’re actively monitoring this issue and will provide updates as they become available.

We’re sorry for any inconvenience being experienced.
Posted Jan 14, 2022 - 18:26 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jan 14, 2022 - 17:44 AEDT
This incident affected: Tyro App.