Tyro Service Status

Banking access issues

Incident Report for Tyro Platform Service

Monitoring

The issue impacting access to the Tyro Banking App and Web Banking has now been identified. If you were impacted by the problem, please reset your password.

We’re very sorry for any inconvenience being caused.
Posted Apr 15, 2026 - 19:55 AEST

Investigating

We’re currently experiencing an issue impacting some customers’ ability to access the Banking App and Web Banking.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience being experienced.
Posted Apr 15, 2026 - 19:54 AEST
This incident affects: Tyro App.