Tyro Service Status

Bushfire support

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 09:58 AEDT

Investigating

Our thoughts are with everyone impacted by bushfires across Australia. If you need assistance, our Customer Support team is here to help on 1300 00 TYRO.
Posted Jan 13, 2026 - 12:58 AEDT
This incident affected: General Announcements.