Tyro Service Status

Issue with Xenta and Xentissimo terminals
Incident Report for Tyro Service Status for Customers
Resolved
This issue has now been resolved. We’re sorry for any inconvenience that was caused.
Posted Dec 31, 2019 - 19:19 AEDT
Monitoring
We have implemented a solution for this issue. Terminals should automatically sign on and work as per normal. If this has not happened and you are still seeing a sign on failed message, please press the Retry button (top right below the screen) which should allow you to sign on.

We will continue to monitor the situation and apologise for the inconvenience experienced.
Posted Dec 31, 2019 - 16:08 AEDT
Update
We are continuing to investigate this issue and will provide further updates as they become available.

We’re sorry for any inconvenience being experienced.
Posted Dec 31, 2019 - 15:24 AEDT
Update
We are currently experiencing sign on issues with Xenta and Xentissimo model terminals.

We're in the process of investigating this issue and will provide further updates on this page as they become
available.

We’re sorry for any inconvenience being experienced.
Posted Dec 31, 2019 - 13:20 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Dec 31, 2019 - 12:39 AEDT
This incident affected: Transaction Processing Systems.