Tyro Service Status

Activation and Pairing
Incident Report for Tyro Platform Service
Resolved
The issue regarding activation and pairing is resolved. Customers should now be able to activate and/or pair their terminals.

We apologise for any inconvenience caused.
Posted May 03, 2024 - 17:32 AEST
Update
We have identified an issue which is resulting in a small subset of Tyro Pro terminals being unable to activate or commence pairing.

Integrated transactions on paired terminals (Y series and Pro) are not impacted and continue to perform as normal.

The team is working on a resolution and updates will be provided here when available. If you need to urgently process transactions and have been unable to activate your Tyro Pro terminal, please contact the Tyro Customer Support team on 1300 00 TYRO. We apologise for any inconvenience caused.
Posted May 03, 2024 - 14:42 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 03, 2024 - 13:36 AEST