Tyro Service Status

Terminal connectivity
Incident Report for Tyro Platform Service
Resolved
We’re aware that some customers may have recently experienced degradation in connectivity to the 3G/4G network between 9.25am-9.35am. Whilst this issue was outside Tyro's control, we can see that our systems have returned to normal. We apologise for any inconvenience experienced.
Posted Oct 18, 2022 - 09:53 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Oct 18, 2022 - 09:39 AEDT