Tyro Service Status

Medicare Easyclaim degraded performance
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 23:25 AEST
Investigating
Medicare is currently experiencing issues, which may affect Medicare Easyclaim from being processed.

This issue is outside Tyro's control however we are actively monitoring any update/progress to ensure our systems return to normal as soon as the issue is resolved.

Please contact Medicare directly for anything urgent.
Posted Jun 04, 2021 - 22:22 AEST
This incident affected: Medicare Easyclaim.