Tyro Service Status

Settlement delays

Incident Report for Tyro Platform Service

Resolved

The issue is resolved. We apologise for any inconvenience experienced.
Posted Jul 31, 2026 - 17:31 AEST

Identified

Please note that some customers may experience a few hours delay to their settlement payment today. This payment may appear at varying times depending on your banking provider. We apologise for any inconvenience experienced.
Posted Jul 31, 2026 - 15:24 AEST

Investigating

We are currently investigating this issue.
Posted Jul 31, 2026 - 15:05 AEST
This incident affected: Settlement.