Tyro Service Status

Settlement delay - Bendigo Bank powered by Tyro customers

Incident Report for Tyro Platform Service

Resolved

Delayed settlements have now been processed - thank you to customers for their understanding as we resolved the issue.
Posted Jul 25, 2025 - 15:24 AEST

Identified

We're aware that settlements for some Bendigo Bank powered by Tyro customers are delayed for 25 July. Our team is working on a resolution and will provide updates here. We apologise for any inconvenience experienced.
Posted Jul 25, 2025 - 09:27 AEST
This incident affected: Settlement.