Tyro Service Status

Medicare Easyclaim degraded performance
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 09:02 AEDT
Monitoring
Medicare is currently experiencing issues, which may affect Medicare Easyclaim from being processed.

This issue is outside Tyro's control however we are actively monitoring any update/progress to ensure our systems return to normal as soon as the issue is resolved.

Please contact Medicare directly for anything urgent.
Posted Mar 14, 2022 - 08:39 AEDT
This incident affected: Medicare Easyclaim.