Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Nov 10, 2019 - 13:31 AEDT
Investigating
We are currently experiencing issues which may affect the ability to process VISA transactions for some customers.

We're in the process of monitoring transaction volumes and will provide an update when transactions have returned to normal.

In the meantime, please try an alternative payment method.
Posted Nov 10, 2019 - 12:13 AEDT
This incident affected: Transaction Processing Systems.