Tyro Service Status

Settlement Delay - Tyro Bank Account customers
Incident Report for Tyro Service Status for Customers
Resolved
Settlement has now been processed for Tyro Bank Account customers. We’re sorry for any inconvenience caused.
Posted Jan 04, 2022 - 14:58 AEDT
Update
Please note that Tyro Bank Account customers have not received their latest settlement payment. We are working to process this payment as quickly as possible and will provide an update once this has been completed. We apologise for any inconvenience experienced.
Posted Jan 04, 2022 - 10:12 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jan 04, 2022 - 09:37 AEDT
This incident affected: Settlement.