Tyro Service Status

Delay of system generated emails

Incident Report for Tyro Platform Service

Resolved

The issue with a delay in emails is now resolved and delayed emails should have come through. Please note, password reset emails would have expired and will need to be requested again. We're sorry for the inconvenience caused.
Posted Jul 23, 2025 - 17:36 AEST

Update

We are currently experiencing an issue where there is a delay in some of the system generated emails that being sent.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience being experienced
Posted Jul 23, 2025 - 12:58 AEST

Identified

A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jul 23, 2025 - 11:51 AEST
This incident affected: Transaction Processing Systems.