Tyro Service Status

Possible system issues
Incident Report for Tyro Service Status for Customers
Resolved
We have confirmed no issue is currently impacting our systems.
Posted Oct 08, 2019 - 13:40 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Oct 08, 2019 - 13:24 AEDT