Tyro Service Status

Transaction Processing

Incident Report for Tyro Platform Service

Resolved

Update: Mastercard transaction processing has returned to normal. Recent transactions may take a little longer than usual to appear across the Tyro Portal, Tyro App and terminals.

Thank you for your understanding during this afternoon.
Posted Aug 15, 2026 - 16:10 AEST

Identified

We are aware of an issue that may be impacting some customers ability to process Mastercard transactions. Please ask your customers to try using their physical Mastercard (not digital wallet) or an alternative payment method.

Whilst this is out of our control, we apologise for any inconvenience experienced and will continue to post updates here as they become available.
Posted Aug 15, 2026 - 15:03 AEST
This incident affected: Transaction Processing Systems.