Tyro Service Status

Activation of EFTPOS machines
Incident Report for Tyro Platform Service
Resolved
We're pleased to confirm the earlier issue regarding terminal activation prompts is now resolved. We apologise for any inconvenience caused.
Posted Sep 13, 2024 - 15:59 AEST
Update
We are aware that some customers are seeing a prompt on their Tyro EFPTOS machine indicating that it is not activated. To activate, customers need to call Customer Support on 1300 00 TYRO (8976), noting that we may be experiencing slightly higher than normal call wait times.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress
Posted Sep 13, 2024 - 11:59 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Sep 13, 2024 - 10:49 AEST
This incident affected: EFTPOS machine connectivity.