Tyro Service Status

Tyro's phone system
Incident Report for Tyro Service Status for Customers
Resolved
This issue with our phone system is now resolved.

We’re sorry for any inconvenience caused to our customers.
Posted May 03, 2021 - 13:43 AEST
Identified
We’ve identified an issue with Tyro’s phone system which may impact some customers reaching Tyro via phone. If you cannot reach us by calling 1300 966 639, please email cs@tyro.com or call again later.

We’re working to resolve this issue and will provide further updates shortly.

We apologise for any inconvenience this is causing customers.
Posted May 03, 2021 - 11:57 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 03, 2021 - 11:32 AEST
This incident affected: Tyro Contact Centre.