Tyro Service Status

Password reset emails

Incident Report for Tyro Platform Service

Resolved

A fix has been implemented to resolve this issue.

We're sorry for any inconvenience experienced.
Posted Jan 31, 2026 - 12:42 AEDT

Update

We’re currently experiencing an issue impacting some merchants receiving password reset emails.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience being experienced.
Posted Jan 31, 2026 - 12:17 AEDT

Investigating

We are currently investigating this issue.
Posted Jan 31, 2026 - 11:31 AEDT
This incident affected: General Announcements.