Tyro Service Status

Easyclaim transactions

Incident Report for Tyro Platform Service

Resolved

This issue has now been resolved.

We're sorry for any inconvenience experienced.
Posted Feb 10, 2025 - 15:52 AEDT

Update

We’re currently experiencing an issue that may be impacting some customers’ ability to process Easyclaim transactions.

The team are investigating this issue, and we’ll continue to provide updates on our progress. We’re sorry for any inconvenience being experienced.
Posted Feb 10, 2025 - 11:26 AEDT

Identified

A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Feb 10, 2025 - 11:01 AEDT
This incident affected: Medicare Easyclaim.