Tyro Service Status

HealthPoint claiming

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 15:59 AEST

Update

We’re aware that HealthPoint is currently experiencing issues, which may be affecting their claims from being processed.

While this issue is outside Tyro's control, we’re actively monitoring the situation and will provide updates as they become available. If urgent, please contact HealthPoint directly.
Posted Jul 07, 2025 - 11:46 AEST

Identified

A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jul 07, 2025 - 11:31 AEST
This incident affected: Healthpoint.