Tyro Service Status

Issues with Tyro Go and Tyro BYO transactions

Incident Report for Tyro Platform Service

Resolved

The issue around PIN resets on the Tyro BYO and Tyro Go apps has been resolved. We apologise for the inconvenience caused.
Posted Feb 14, 2026 - 08:02 AEDT

Update

The issue surrounding transactions for Tyro BYO and Go is resolved.

Please note, we are seeing some issues with customers being able to reset their PIN. If you are able to, please delay password reset activity until a later time. If you are unable to access the Tyro BYO or Tyro Go app, please use the interim solution mentioned below if you are able to.

We apologise for the inconvenience caused and will provide an update on resolution.
Posted Feb 13, 2026 - 17:29 AEDT

Update

We’re currently investigating an issue impacting transaction processing for Tyro Go and Tyro BYO App customers. Our team is actively working to resolve this as a priority and we’ll continue to provide updates here on our progress.

CounterTop, Mobile, Tyro Pro EFTPOS machines and eCommerce transactions are not impacted.

As an interim solution you may be able to process Payment Links in the Tyro Portal – steps can be found here on how to take payments via Payment Links - https://help.tyro.com/s/article/Payment-Links-in-Tyro-Portal

We apologise for the inconvenience caused
Posted Feb 13, 2026 - 10:35 AEDT

Investigating

We are currently investigating this issue.
Posted Feb 13, 2026 - 10:05 AEDT
This incident affected: Transaction Processing Systems.