Tyro Service Status

Tyro Portal
Incident Report for Tyro Service Status for Customers
Resolved
We have resolved the issue with the Tyro Portal. We apologise for the inconvenience caused.
Posted May 16, 2021 - 19:02 AEST
Identified
An issue has been identified where some customers are unable to log into the Tyro Portal. We are currently investigating this issue and will provide updates as they become available.

EFTPOS machine and Tyro App reporting remains unaffected.

We’re sorry for any inconvenience being experienced.
Posted May 16, 2021 - 17:28 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 16, 2021 - 17:00 AEST
This incident affected: Tyro Portal.