Tyro Service Status

Minor settlement delay – Tyro Bank Account
Incident Report for Tyro Service Status for Customers
Resolved
Transferred funds from the Tyro Bank Account this afternoon should now be settled.

We’re sorry for any inconvenience caused to our customers.
Posted Dec 10, 2019 - 20:41 AEDT
Identified
There is a minor delay with transfers out of the Tyro Bank Account since 1pm. This might cause settlement of these funds to be slightly delayed.

We're in the process of resolving this issue and will provide further updates on this page as they become available.

We’re sorry for any inconvenience being experienced.
Posted Dec 10, 2019 - 17:22 AEDT
This incident affected: Settlement.