Tyro Service Status

Intermittent processing issues - Mastercard
Incident Report for Tyro Service Status for Customers
Resolved
We recently experienced some intermittent connectivity issues which may have affected the ability for some customers to process Mastercard transactions. We’re sorry for any inconvenience experienced.
Posted Mar 29, 2020 - 20:36 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Mar 29, 2020 - 20:13 AEDT
This incident affected: Transaction Processing Systems.