Tyro Service Status

Bendigo Bank powered by Tyro Settlement
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 08:41 AEST
Monitoring
Bendigo Bank Powered by Tyro customers who receive 7-day settlement will experience a few hours delay to their funds arriving today.

We’re sorry for any inconvenience experienced.
Posted Jul 14, 2024 - 10:15 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jul 14, 2024 - 07:53 AEST
This incident affected: Settlement.