Tyro Service Status

Tyro Customer Support
Incident Report for Tyro Platform Service
Resolved
Tyro's Customer Support line is available again and our agents are ready to take your call. We apologise for any inconvenience experienced.
Posted Sep 22, 2023 - 16:26 AEST
Identified
We are aware that customers may be experiencing issues when trying to call our Customer Support lines. Our team is urgently working on a fix and we appreciate your understanding if trying to get in contact.

If you require immediate assistance, please email cs@tyro.com with the subject "Urgent support" or send us a DM via our facebook page.

We apologise for any inconvenience being experienced.
Posted Sep 22, 2023 - 15:48 AEST
This incident affected: Tyro Contact Centre.