Tyro Service Status

Delayed Settlements
Incident Report for Tyro Platform Service
Resolved
Some customers may have experienced delayed settlements earlier today. This issue has now been fixed. If your settlement has not yet appeared, please contact your bank directly.
Posted Feb 11, 2019 - 16:44 AEDT
Investigating
Tyro is aware of an industry wide issue affecting the ability to process settlements with all Australian banks likely to be impacted. This is outside Tyro’s control however we’re continuing to monitor the situation and will provide further updates as soon as they become available. Please refer to our status page at status.tyro.com for the latest updates.
Posted Feb 11, 2019 - 11:50 AEDT
This incident affected: Settlement.