Tyro Service Status

Possible system issues
Incident Report for Tyro Service Status for Customers
Resolved
This incident was triggered due to a system alert for higher than normal call volumes. We have investigated this and conclude that there is no impact to Tyro's systems.
This has now been resolved.
Posted Jan 29, 2020 - 14:52 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jan 29, 2020 - 13:51 AEDT
This incident affected: Tyro Contact Centre.