Tyro Service Status

Connectivity Issues
Incident Report for Tyro Service Status for Customers
Resolved
The issue is now resolved and systems have returned to normal. If you are still experiencing any transacting difficulty, please reboot the EFTPOS machine by holding down the yellow button.

We’re sorry for any inconvenience caused to you and your customers.
Posted Sep 01, 2022 - 11:43 AEST
Identified
We're aware of an issue which is impacting some customers ability to connect to the EFTPOS machine and transact. Some customers may also not be able to log into the Tyro App. Please try rebooting the EFTPOS machine by holding down the yellow button.

We are urgently working on a resolution and will provide updates as they become available. We’re sorry for any inconvenience being experienced.
Posted Sep 01, 2022 - 11:23 AEST
This incident affected: EFTPOS machine connectivity and Tyro App.