Tyro Service Status

Settlement Delay
Incident Report for Tyro Service Status for Customers
Resolved
Update: All our systems are now operational and settlements have been processed.

For customers who settle to a Linked Bank Account, your funds have been processed 3 hours later than normal. Please note the time they become available will depend on your banking provider.

There are however delays to reporting which means recent transactions may not appear on today's transaction and reconciliation reports. These transactions will appear at a later time and will be included in settlement.

We understand the frustration this has caused to you and your staff today and apologise for the impact caused.
Posted May 17, 2021 - 16:18 AEST
Identified
Unfortunately our usual settlement time will be delayed today. This is due to an issue we experienced earlier this morning. We are working urgently to process settlements today and we will provide updates as soon as they are available.

The Tyro App and Portal are still unavailable.

We are very sorry for the frustration and inconvenience caused.
Posted May 17, 2021 - 13:25 AEST
This incident affected: Settlement, Tyro Portal, and Tyro App.