Tyro Service Status

Log in issues with Tyro Go app
Incident Report for Tyro Platform Service
Resolved
Log in to the Tyro Go App is available again. We’re very sorry for any inconvenience caused to you and your customers. Thanks, the Tyro Team
Posted Feb 04, 2024 - 11:34 AEDT
Identified
We’re currently experiencing an issue impacting customers’ ability to log in to the Tyro Go app. As a workaround, Tyro Go customers with an iPhone version 1.2.0 (iOS 16.4) can take transactions via Tap to Pay on iPhone. Please download the Tyro BYO app and log in using the same credentials as Tyro Go. Further information can be found via this help article- https://help.tyro.com/s/article/Tyro-BYO-Tap-and-Pay-on-iPhone-FAQs.

Access to the Tyro Portal, Tyro App, Tyro BYO App are not impacted.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience caused
Posted Feb 04, 2024 - 10:00 AEDT
This incident affected: Tyro App.