Tyro Service Status

Potential settlement delay
Incident Report for Tyro Service Status for Customers
Resolved
The earlier issue regarding delayed settlement which affected a small number of customers has now been resolved and all settlements have been processed.

Please note that the time your settlement funds appear in your account may be slightly later than normal as each bank has different processing times.

We’re sorry for any inconvenience being experienced.
Posted Jul 01, 2020 - 15:30 AEST
Monitoring
We have identified an issue which may affect the ability to process settlements for some customers.

We will provide further updates on this page as they become available.

We’re sorry for any inconvenience being experienced.
Posted Jul 01, 2020 - 11:24 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jul 01, 2020 - 10:07 AEST
This incident affected: Settlement.