Tyro Service Status

Tyro's Medicare Easyclaim solution
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Jul 12, 2019 - 08:11 AEST
Update
Connectivity has now been restored and Tyro's Medicare Easyclaim solution can again be used. We apologise for the inconvenience caused to our customers.
Posted Jul 11, 2019 - 18:08 AEST
Monitoring
Due to an outage we advise not using Tyro's Medicare Easyclaim solution at this time. Please advise patients that they will need to complete their claim using an alternative method. This issue is outside Tyro's control however we are actively monitoring any update/progress to ensure our systems return to normal as soon as the issue is resolved.

Please contact Medicare directly for anything urgent.
Posted Jul 11, 2019 - 15:52 AEST
This incident affected: Medicare Easyclaim.